Technology

Security Jaringan dari Serangan Virus dengan Mikrotik

 
  • 85
    Shares

Loading...

Sebagai salah satu bentuk pengamanan jaringan internet kita dari packet data yang tidak diinginkan atau virus, kita bisa menambahkan rule pada firewall Mikrotik untuk melakukan block pada packet tersebut. Berikut langkah-langkah untuk melakukan blocking terhadap paket atau virus tersebut:

  • Yang pertama kita lakukan adalah menambahkan command berikut melalui Terminal di Winbox

 

[message_box color=”green”]/ip firewall filter
add chain=forward connection-state=established comment=”allow established connections”
add chain=forward connection-state=related comment=”allow related connections”
add chain=forward connection-state=invalid action=drop comment=”drop invalid connections”[/message_box]

Disini kita mengijinkan koneksi yang sudah dibuka dan yang terkait, sedangkan untuk paket koneksi yang tidak dipercaya akan di drop

  • Kemudian kita tambahkan kembali filter untuk menyaring paket-paket yang tidak diinginkan. Misalnya dari suatu host yang sudah terinfeksi virus, anda bisa langsung mencopy command di bawah ini untuk melakukan block terhadap port-port yang digunakan oleh virus jika anda masih berada pada menu /ip firewall filter

 

[message_box color=”green”]add chain=virus protocol=tcp dst-port=135-139 action=drop comment=”Drop Blaster Worm”
add chain=virus protocol=udp dst-port=135-139 action=drop comment=”Drop Messenger Worm”
add chain=virus protocol=tcp dst-port=445 action=drop comment=”Drop Blaster Worm”
add chain=virus protocol=udp dst-port=445 action=drop comment=”Drop Blaster Worm”
add chain=virus protocol=tcp dst-port=593 action=drop comment=”________”
add chain=virus protocol=tcp dst-port=1024-1030 action=drop comment=”________”
add chain=virus protocol=tcp dst-port=1080 action=drop comment=”Drop MyDoom”
add chain=virus protocol=tcp dst-port=1214 action=drop comment=”________”
add chain=virus protocol=tcp dst-port=1363 action=drop comment=”ndm requester”
add chain=virus protocol=tcp dst-port=1364 action=drop comment=”ndm server”
add chain=virus protocol=tcp dst-port=1368 action=drop comment=”screen cast”
add chain=virus protocol=tcp dst-port=1373 action=drop comment=”hromgrafx”
add chain=virus protocol=tcp dst-port=1377 action=drop comment=”cichlid”
add chain=virus protocol=tcp dst-port=1433-1434 action=drop comment=”Worm”
add chain=virus protocol=tcp dst-port=2745 action=drop comment=”Bagle Virus”
add chain=virus protocol=tcp dst-port=2283 action=drop comment=”Drop Dumaru.Y”
add chain=virus protocol=tcp dst-port=2535 action=drop comment=”Drop Beagle”
add chain=virus protocol=tcp dst-port=2745 action=drop comment=”Drop Beagle.C-K”
add chain=virus protocol=tcp dst-port=3127-3128 action=drop comment=”Drop MyDoom”
add chain=virus protocol=tcp dst-port=3410 action=drop comment=”Drop Backdoor OptixPro”
add chain=virus protocol=tcp dst-port=4444 action=drop comment=”Worm”
add chain=virus protocol=udp dst-port=4444 action=drop comment=”Worm”[/message_box]

Dengan command di atas kita memblok protocol dan port yang digunakan oleh virus, untuk rule tersebut belum lengkap karena masih banyak lagi port dan protocol yang harus ditambahkan. Jadi mungkin ke depannya anda bisa mencoba untuk menambahkan rule tersebut.

  • Kemudian tambahkan action=jump agar paket koneksi membaca list virus terlebih dahulu sebelum di teruskan oleh rule yang pertama kita buat sebelumnya.

 

[message_box color=”green”]add chain=forward action=jump jump-target=virus comment=”jump to the virus chain”[/message_box]

Jika paket tidak masuk di daftar virus, maka paket akan diteruskan ke rule pertama.


Selamat mencoba.

Loading...

  • 85
    Shares

1 komentar

  • Erwin
    3 Desember 2012 - pukul 11:24

    terima kasih tutorialnya sangat membantu…di tunggu tutor yg lainya master…hehehe

Berikan Komentar

Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *