Technology

Pengamanan dari Gangguan Brute Force pada Jaringan Mikrotik

 

Loading...

Berikut ini salah satu pencegahan dari aktivitas Brute Force, di mana aktivitas ini merupakan salah satu cara hacker masuk ke dalam server. Yaitu dengan berulang-ulang mencoba berbagai kombinasi password untuk menjebol login kita. Tutorial kali ini, kita akan mencoba setting dengan terminal pada winbox.

1. Mengijinkan login salah hanya 10 kali dalam semenit

  • Kita perlu setting filter rule dulu pada firewall. Silakan masuk ke direktori Filter Rule, kemudian ketik /ip firewall filter

  • Melakukan drop FTP pada IP yang telah di blacklist. Ketik add chain=input protocol=tcp dst-port=21 src-address-list=ftp_blacklist action=drop \ comment=”drop ftp brute forcers”. Hasilnya bisa dicek pada menu IP > FIREWALL > FILTER RULE

  • Menangkap IP yang melakukan login salah dalam 1 menit. Ketik: add chain=output action=accept protocol=tcp content=”530 Login incorrect” dst-limit=1/1m,9,dst-address/1m
  • Membuat listing terhadap IP – IP pelaku Brute Force. Ketik: add chain=output action=add-dst-to-address-list protocol=tcp content=”530 Login incorrect” \ address-list=ftp_blacklist address-list-timeout=3h

 

2. Banned 10 hari pada pelaku Brute Force melalui SSH mikrotik

  • Silakan langsung copy paste setting di bawah ini ke terminal anda:

[message_box color=”green”]

add chain=input protocol=tcp dst-port=22 src-address-list=ssh_blacklist action=drop \
comment=”drop ssh brute forcers” disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new \
src-address-list=ssh_stage3 action=add-src-to-address-list address-list=ssh_blacklist \
address-list-timeout=10d comment=”” disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new \
src-address-list=ssh_stage2 action=add-src-to-address-list address-list=ssh_stage3 \
address-list-timeout=1m comment=”” disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new src-address-list=ssh_stage1 \
action=add-src-to-address-list address-list=ssh_stage2 address-list-timeout=1m comment=”” disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new action=add-src-to-address-list \
address-list=ssh_stage1 address-list-timeout=1m comment=”” disabled=no

[/message_box]

  • Hasilnya bisa dicek pada menu: IP > FIREWALL > FILTER RULE, di bagian paling bawah.
  • Anda bisa setting secara lebih spesifik lagi untuk SSH dan FTP ke IP mana dalam jaringan anda dengan mengisikan Dst Address List pada setting Action Drop:

  • Selamat mencoba
Loading...

Berikan Komentar

Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *